On Thu, Jul 03, 2008 at 08:32:59AM +0200, Sune Vuorela wrote:
> > > I think either way we should try to push forward with samba 3.2 for
> > > lenny; it's just a question of whether we also have to invest time into
> > > getting a GPLv2 libsmbclient package ready.

> > When we talked about this some months ago, nobody looked at the exact KDE
> > files because the main blocker was Qt3 licence, but this was updated in the
> > beginning of this year to GPL v3 too and current qt3 is lenny has an
> > updated copyright file.

> > Then, in kdebase it seems the only code that links against libsmbclient is
> > the smb kioslave, the code is placed at kdebase/kioslave/smb/ and all the
> > headers say GPL v2.1 or later. If somebody wants to take a quick check to
> > see if i am overlooking something is welcome.

> But kdelibs needs also to get a look. At least in theory, it is LGPL, but it 
> is some time ago I have last reviewed all files in kdelibs.

So at this point, we in the Debian Samba team are operating on the
assumption that the GPLv3 compatibility issues for KDE libsmbclient support
have been sorted out, or that any remaining issues can be sorted out before
release, and that we're ok to ship Samba 3.2.0 in lenny without also
providing a 3.0 library for license compatibility.

Thanks for your feedback.

-- 
Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
Ubuntu Developer                                    http://www.debian.org/
[EMAIL PROTECTED]                                     [EMAIL PROTECTED]

-- 
http://lists.alioth.debian.org/mailman/listinfo/pkg-kde-talk

Reply via email to