Package: release.debian.org
Severity: normal
User: release.debian....@packages.debian.org
Usertags: transition

Hello,

I would like to ask for a slot to do the KDE SC 4.6 transition. It is already
somewhat overdue (with respect to 4.6.0 release upstream) so doing it sooner
(in a week or so) rather than later would be very appreciated. This transition
would include immediate update of the following KDE SC and related source
packages:

* From 4:4.4.5 to 4:4.6.2 or later (stable 4.6.x series):

    meta-kde
    kde-l10n
    kde4libs
    kdeaccessibility
    kdeadmin
    kdeartwork
    kdebase
    kdebase-runtime
    kdebase-workspace
    kdeedu
    kdegames
    kdegraphics
    kdemultimedia
    kdenetwork
    kdepimlibs
    kdeplasma-addons
    kdesdk
    kdetoys
    kdeutils
    kdewebdev
    oxygen-icons

* From 4:4.4.7 to 4:4.4.11

    kdepim
    kdepim-runtime

* KDE SC 4.6 dependencies:

    akonadi
    libktorrent
    polkit-kde-1
    polkit-qt-1

They are in experimental at the moment. What is more, packaging got some
(significant) testing from some of our users while packages were provided via
external repository. Even if all KDE libraries have symbol files, rebuilt
external packages might still pick up new symbols via modified inline functions
in the headers. Though this technique is mostly used by Qt rather than KDE so
widespread "shlibs bump" effect is unlikely.

It's not very clear to me (personally) what to do with kdebindings but IMHO if
possible, it's better to delay it sometime after this transition. This ugly
beast links the whole distro together.

Packages that are affected by transition (and KDE dependencies which break
them) are below:

Michael Banck <mba...@debian.org>
   libopensync-plugin-kdepim - by kdepimlibs5/src:kdepimlibs

Debian KDE Extras Team <pkg-kde-ext...@lists.alioth.debian.org>
   digikam           - by libmarblewidget4/src:kdeedu
                          libkdcraw8/src:kdegraphics
                          libkexiv2-8/src:kdegraphics
                          libkipi7/src:kdegraphics

   kipi-plugins      - by libkdcraw8/src:kdegraphics
                          libkexiv2-8/src:kdegraphics
                          libkipi7/src:kdegraphics

   kmess             - by libkonq5/src:kdebase

   knights           - by libkdegames5/src:kdegames

   konq-plugins      - by libkonq5/src:kdebase

   kphotoalbum       - by libmarblewidget4/src:kdeedu
                          libkdcraw8/src:kdegraphics
                          libkipi7/src:kdegraphics

   krusader          - by libkonq5/src:kdebase

   ktorrent          - by libktorrent2/src:libktorrent
                          libsolidcontrol4/src:kdebase-workspace
                          libtaskmanager4a/src:kdebase-workspace

   networkmanagement - by libsolidcontrol4/src:kdebase-workspace

Debian Qt/KDE Maintainers <debian-qt-...@lists.debian.org>
   kdevelop       - incompatible with kde4libs 4:4.6
   kdevelop-pg-qt - needed by kdevelop
   kdevelop-php   - needs to be in sync kdevelop
   kdevplatform   - needed by kdevelop

Yann Dirson <dir...@debian.org>
   tagua                         - by libkdegames5/src:kdegames

Davi Leal <d...@gnu.org>
   plasma-widget-adjustableclock - by libplasmaclock4a/src:kdebase-workspace

Salvo Rinaldi <sal...@cryptolab.net>
   plasma-widget-smooth-tasks    - by libtaskmanager4a/src:kdebase-workspace

Eike Sauer <e...@debian.org>
   kdiff3                        - by libkonq5/src:kdebase

Kai Wasserb├Ąch <cu...@debian.org>
   plasma-widget-yawp            - by libweather-ion4a/src:kdebase

Tasks:

* libopensync-plugin-kdepim is RC buggy (#569382) even if from KDE POV, binNMU
  should be enough. I think the package can be removed if needed.
* digikam and kipi-plugins - new upstream versions have to be packaged (I could
  handle that in case Mark Purcell had no time).
* knights - ready to be uploaded.
* konq-plugins - new upstream version will be prepared.
* konq-plugins-l10n will have to be removed from the archive.
* ktorrent - ready in experimental.
* kdevelop, kdevelop-pg-qt, kdevelop-php, kdevplatform - new upstream versions
  are ready to be uploaded.
* binNMU others (I wouldn't expect them to FTBFS):

    nmu kmess_2.0.6.1-1 . ALL . -m "KDE SC 4.6 transition"
    nmu kphotoalbum_4.1.1-3 . ALL . -m "KDE SC 4.6 transition"
    nmu krusader_1:2.3.0~beta1-1 . ALL . -m "KDE SC 4.6 transition"
    nmu networkmanagement_0.1+git20110422.810bc16-1 . ALL . -m "KDE SC 4.6 
transition"
    nmu tagua_1.0~alpha2-9 . ALL . -m "KDE SC 4.6 transition"
    nmu plasma-widget-adjustableclock_2.2-1 . ALL . -m "KDE SC 4.6 transition"
    nmu plasma-widget-smooth-tasks_0.0~wip20100227-1.1 . ALL . -m "KDE SC 4.6 
transition"
    nmu kdiff3_0.9.95-7 . ALL . -m "KDE SC 4.6 transition"
    nmu plasma-widget-yawp_0.3.6-2 . ALL . -m "KDE SC 4.6 transition"

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (110, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.38-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=lt_LT.UTF-8, LC_CTYPE=lt_LT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash



--
http://lists.alioth.debian.org/mailman/listinfo/pkg-kde-talk

Reply via email to