On 03/19/2014 11:36 AM, Ansgar Burchardt wrote:
> enigmail build-depends on an old version of icedove-dev. The requirement
> is no longer fulfilled in unstable which has a more recent version.
> 
> It looks like 1.6 should also work with more recent versions of icedove:
> the upstream download link reads "v1.6 for Linux (32-bit) on Thunderbird
> 24.0".

yep, the 1.6 source code works for both 17.x and 24.x -- build-depending
against < 19.0 allows the binary package to work with both versions of
icedove.

newer (as yet unreleased) versions of enigmail upstream will only
support 24.x and later, and so the build-dependency will obviously have
to change then.

we can also change the build dependency in unstable and greatly simplify
the 1.6-x packaging, as long as icedove 17.x being unsupported.  If we
do this right now, enigmail will no longer work on hurd-i386 (because
icedove doesn't build there), but i guess that's a price the hurd folks
will have to pay.

I'll work on simplifying enigmail and releasing 1.6-5 in the next day or
two.  Backports to wheezy will need to maintain the crufty extra
packaging at least as long as we're supporting 17 in wheezy-security,
but using git for our packaging helps a lot for this.

thanks for the heads-up, Ansgar.

        --dkg

Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
Pkg-mozext-maintainers mailing list
Pkg-mozext-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-mozext-maintainers

Reply via email to