Package: mozilla-devscripts
Version: 0.39
Severity: important

Currently, it looks like mozilla-devscripts generates Depends: and Breaks:
versions directly from <minVersion>.

However, Debian versions and Mozilla versions are different. For example,
currently icedove-dev is at version 30.0~b1-1, which in Debian sorts *before*
30.0. However, the Mozilla XUL_VERSION is 30.0 even for beta builds. This means
I have to declare a Build-Depends: on icedove-dev (>= 30.0~~) for things to
work. OK, this is not too bad.

However, the binary packages still result in a Depends and Breaks version of
30.0, not 30.0~~, which means that are not installable. I suggest we append ~~
to these version strings, to handle the case where the Debian release of
iceweasel/icedove is itself a beta or rc.

-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (500, 'stable'), (1, 
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.12-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages mozilla-devscripts depends on:
ii  perl           5.18.2-4
ii  python         2.7.6-1
ii  python-librdf
ii  unzip          6.0-12
ii  zip            3.0-8

mozilla-devscripts recommends no packages.

mozilla-devscripts suggests no packages.

-- no debconf information

Pkg-mozext-maintainers mailing list

Reply via email to