On 01/06/14 16:25, Ximin Luo wrote:
> Currently, it looks like mozilla-devscripts generates Depends: and Breaks:
> versions directly from <minVersion>.
> 
> However, Debian versions and Mozilla versions are different. For example,
> currently icedove-dev is at version 30.0~b1-1, which in Debian sorts *before*
> 30.0. However, the Mozilla XUL_VERSION is 30.0 even for beta builds. This 
> means
> I have to declare a Build-Depends: on icedove-dev (>= 30.0~~) for things to
> work. OK, this is not too bad.
> 

This is MOZILLA_VERSION (and friends) in /usr/include/icedove/mozilla-config.h

> However, the binary packages still result in a Depends and Breaks version of
> 30.0, not 30.0~~, which means that are not installable. I suggest we append ~~
> to these version strings, to handle the case where the Debian release of
> iceweasel/icedove is itself a beta or rc.
> 

It looks like a single ~ works as well - I guess in normal situations we'll 
only have "version~beta" so (>= version~) should cover this adequately.

-- 
GPG: 4096R/1318EFAC5FBBDBCE
git://github.com/infinity0/pubkeys.git

Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
Pkg-mozext-maintainers mailing list
Pkg-mozext-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-mozext-maintainers

Reply via email to