On Wed, Mar 17, 2010 at 04:53:48PM -0300, Felipe Sateler wrote:
On Wed, Mar 17, 2010 at 15:56, Jonas Smedegaard <d...@jones.dk> wrote:
There is a problem, though. The library names collide, so one would have to have libjack1-0 and libjack2-0. This would mean that the shlibs files would have to provide alternative dependencies (like ffmpeg is doing for the unstripped variants), which would require a binNMU run to change the dependencies, and finally then jack2 could be uploaded. Oh and take steps to make sure jackd1 depends on libjack1-0 only (and same for jack2). I think this is much too complicated.


Oh, you mean both use unversioned soname?

Yes, that complicates things.

It is not an unversioned soname. Both versions are ABI compatible, thus have the same soname.

Ah. I got it now (and understand the problems you described).

Thanks for clarifying :-)


 - Jonas

--
* Jonas Smedegaard - idealist & Internet-arkitekt
* Tlf.: +45 40843136  Website: http://dr.jones.dk/

 [x] quote me freely  [ ] ask before reusing  [ ] keep private

Attachment: signature.asc
Description: Digital signature

_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to