Your message dated Tue, 13 Sep 2011 14:50:29 +0000
with message-id <e1r3ujh-0003uf...@franck.debian.org>
and subject line Bug#624604: fixed in openlayers 2.11+ds1-1
has caused the Debian Bug report #624604,
regarding libjs-openlayers: resources aren't made available via web browser
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
624604: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=624604
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: libjs-openlayers
Version: 2.10+ds1-2
Severity: important
Tags: patch

The current patch/00-fix_data_paths.patch uses the local path to resources,
e.g. /usr/share/openlayers/img/, however when accessing the library through a
web browser via the javascript-common package (e.g.
http://localhost/javascript/openlayers/OpenLayers.js) these local paths are no
longer valid.

To make the img and theme content available over the web, symlink
them into /usr/share/javascript/openlayers/ and then drop
patch/00-fix_data_paths.patch.

patch suggestion is add file debian/libjs-openlayers.links with content
/usr/share/openlayers/theme /usr/share/javascript/openlayers/theme
/usr/share/openlayers/img /usr/share/javascript/openlayers/img

and drop patch/00-fix_data_paths.patch (then fix patch/series)



--- End Message ---
--- Begin Message ---
Source: openlayers
Source-Version: 2.11+ds1-1

We believe that the bug you reported is fixed in the latest version of
openlayers, which is due to be installed in the Debian FTP archive:

libjs-openlayers-doc_2.11+ds1-1_all.deb
  to main/o/openlayers/libjs-openlayers-doc_2.11+ds1-1_all.deb
libjs-openlayers_2.11+ds1-1_all.deb
  to main/o/openlayers/libjs-openlayers_2.11+ds1-1_all.deb
openlayers_2.11+ds1-1.debian.tar.gz
  to main/o/openlayers/openlayers_2.11+ds1-1.debian.tar.gz
openlayers_2.11+ds1-1.dsc
  to main/o/openlayers/openlayers_2.11+ds1-1.dsc
openlayers_2.11+ds1.orig.tar.gz
  to main/o/openlayers/openlayers_2.11+ds1.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 624...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
David Paleino <da...@debian.org> (supplier of updated openlayers package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 13 Sep 2011 15:51:28 +0200
Source: openlayers
Binary: libjs-openlayers libjs-openlayers-doc
Architecture: source all
Version: 2.11+ds1-1
Distribution: unstable
Urgency: low
Maintainer: Debian OpenStreetMap Team <pkg-osm-maint@lists.alioth.debian.org>
Changed-By: David Paleino <da...@debian.org>
Description: 
 libjs-openlayers - JavaScript library for displaying map data in web browsers
 libjs-openlayers-doc - documentation for OpenLayers
Closes: 624604 636358
Changes: 
 openlayers (2.11+ds1-1) unstable; urgency=low
 .
   * New upstream release
   * Make resources available from a web browser, thanks to Andrew Harvey
     (Closes: #624604)
   * Added README.Debian, thanks to Marcelo Jorge Vieira (Closes: #636358)
Checksums-Sha1: 
 0eb9e335745dbded0d018d07b0c5f8337522158e 1325 openlayers_2.11+ds1-1.dsc
 6fad8d734c87cd690b2bdf72339c6ce68ab94c7d 7775220 
openlayers_2.11+ds1.orig.tar.gz
 cc61d505b4b07239388db25ee071d1140ea1a421 4260 
openlayers_2.11+ds1-1.debian.tar.gz
 72ad44ea526a652891ffcc6817512dd062d95bbb 828234 
libjs-openlayers_2.11+ds1-1_all.deb
 aed64dfff5932076cd71859eefde64904c53eb42 3680494 
libjs-openlayers-doc_2.11+ds1-1_all.deb
Checksums-Sha256: 
 0a7b182d17927cde9bea92f0282271a1082e392b6c42bf79d6ea133002697700 1325 
openlayers_2.11+ds1-1.dsc
 5a572c0d20f2fd7127806ae45ca1fb8f130b7dc2f45145d888d29c154f5f8971 7775220 
openlayers_2.11+ds1.orig.tar.gz
 22edf25d9a56540be59d5b9eb3a02ce9b79bdc8dfa1b1b019b4a74de0562d787 4260 
openlayers_2.11+ds1-1.debian.tar.gz
 1cd07195a832b2fb3eb5cc9cd629983992faecb81353f6ecffdf3223555012af 828234 
libjs-openlayers_2.11+ds1-1_all.deb
 28c08791419ed2f307336b21cf6d91f755e77ed91e7b41baf939ba90493899b7 3680494 
libjs-openlayers-doc_2.11+ds1-1_all.deb
Files: 
 73a386528f60a28e408648ea2edaf64b 1325 web extra openlayers_2.11+ds1-1.dsc
 864d72d1d2a873b8f9ee203c7d956363 7775220 web extra 
openlayers_2.11+ds1.orig.tar.gz
 bef8affd4adf8a3c74ad782c63f13cc6 4260 web extra 
openlayers_2.11+ds1-1.debian.tar.gz
 c912cba211c6c68348c1763d68cc904c 828234 web extra 
libjs-openlayers_2.11+ds1-1_all.deb
 213121beeea4e6e56d7b0b6487a078e1 3680494 doc extra 
libjs-openlayers-doc_2.11+ds1-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEARECAAYFAk5vYSUACgkQ5qqQFxOSsXS50ACgvxU5oKh5fpX1vl9HqcKQhcS9
AGsAoMpbwJrqn8sHMr06dEgxnfOJAefF
=472u
-----END PGP SIGNATURE-----



--- End Message ---
_______________________________________________
Pkg-osm-maint mailing list
Pkg-osm-maint@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-osm-maint

Reply via email to