Your message dated Sat, 05 Aug 2017 14:55:51 +0000
with message-id <e1de0uz-0007rt...@fasolo.debian.org>
and subject line Bug#857375: fixed in ruby-jar-dependencies 0.3.10-2
has caused the Debian Bug report #857375,
regarding ruby-jar-dependencies: fails to upgrade from 'jessie' - trying to 
overwrite /usr/lib/ruby/vendor_ruby/rubygems_plugin.rb
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
857375: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=857375
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: ruby-jar-dependencies
Version: 0.3.10-1
Severity: serious
User: debian...@lists.debian.org
Usertags: piuparts

Hi,

during a test with piuparts I noticed your package fails to upgrade from
'jessie'.
It installed fine in 'jessie', then the upgrade to 'stretch' fails
because it tries to overwrite other packages files without declaring a
Breaks+Replaces relation.

See policy 7.6 at
https://www.debian.org/doc/debian-policy/ch-relationships.html#s-replaces

>From the attached log (scroll to the bottom...):

  Selecting previously unselected package ruby-jar-dependencies.
  Preparing to unpack .../ruby-jar-dependencies_0.3.10-1_all.deb ...
  Unpacking ruby-jar-dependencies (0.3.10-1) ...
  dpkg: error processing archive 
/var/cache/apt/archives/ruby-jar-dependencies_0.3.10-1_all.deb (--unpack):
   trying to overwrite '/usr/lib/ruby/vendor_ruby/rubygems_plugin.rb', which is 
also in package yard 0.8.7.4-1
  Errors were encountered while processing:
   /var/cache/apt/archives/ruby-jar-dependencies_0.3.10-1_all.deb


cheers,

Andreas

Attachment: yard=0.8.7.4-1_ruby-jar-dependencies=0.3.10-1.log.gz
Description: application/gzip


--- End Message ---
--- Begin Message ---
Source: ruby-jar-dependencies
Source-Version: 0.3.10-2

We believe that the bug you reported is fixed in the latest version of
ruby-jar-dependencies, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 857...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Miguel Landaeta <nomad...@debian.org> (supplier of updated 
ruby-jar-dependencies package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Sat, 05 Aug 2017 15:19:12 +0100
Source: ruby-jar-dependencies
Binary: ruby-jar-dependencies
Architecture: source
Version: 0.3.10-2
Distribution: unstable
Urgency: medium
Maintainer: Debian Ruby Extras Maintainers 
<pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Changed-By: Miguel Landaeta <nomad...@debian.org>
Description:
 ruby-jar-dependencies - manage jar dependencies for Ruby gems
Closes: 857375
Changes:
 ruby-jar-dependencies (0.3.10-2) unstable; urgency=medium
 .
   * Remove /usr/lib/ruby/vendor_ruby/rubygems_plugin.rb since is causing
     upgrade problems. (Closes: #857375)
   * Bump Standards-Versions to 4.0.0. No changes were required.
   * Update copyright information.
Checksums-Sha1:
 55cb31aa37f6df0df0f9dceecac6d77c73dcee75 2137 
ruby-jar-dependencies_0.3.10-2.dsc
 6160f255dae01c6e0f0939ffca33f3aca7f74c27 2888 
ruby-jar-dependencies_0.3.10-2.debian.tar.xz
Checksums-Sha256:
 2f400a75c1e93bb97dff5861578557b6d8bd00d9f48e1af252f4adec4a5f2d52 2137 
ruby-jar-dependencies_0.3.10-2.dsc
 eed3983779f5c67cac7e889ecff29a4bc89d860493254795fc52cc670bdf2e66 2888 
ruby-jar-dependencies_0.3.10-2.debian.tar.xz
Files:
 98e4d48da15e9d37ee8291e4f8f01801 2137 ruby optional 
ruby-jar-dependencies_0.3.10-2.dsc
 f86de5af3b4baa6dd3b1f4b1d9efc7cc 2888 ruby optional 
ruby-jar-dependencies_0.3.10-2.debian.tar.xz

-----BEGIN PGP SIGNATURE-----

iQIcBAEBCgAGBQJZhdSkAAoJEK+44PySMcxtzLIQAKR+B9v47edw5b/UwhmerI0M
fMgG+K5aAhLkMZ8tQf7lvotPQqRFX/Mgp8kduDa1Lpqyx4pSGDh4PerrzN2nhz9/
SCi7lHo4hQduBXIpqNg7B+kcJHFEFFuoS6wrFKhkiViRnyl3VTsr3goHQJkGSsWW
iaeamUCGEhdM8odLHWLoHnrfwgkzXVNHKsEKGnMR4ecaIImsvXOerVeIeLVEXwqf
dBIJUISZZoWH85Yj+MZv7ZMZUNsj0baLZhJu2oXzMdUwCJ/uY5QSchvdH6zK/HIE
jmtL0e98z3omLPe7ODeyxObsZe7kB6Nzy4DeLd/rCBuJjuQpw5QLVrqr5lUlXeF3
4XSbwkBQno7MTjipRTjtwa2BEh6YxbttA7/7qVzGpDaLe+fIQgbBSsbJsRMOxKWz
8NQaL8WXROgh4lKfnIFtKpShOAOot1qJTnNJ86PVRnLMEu3ismOaN5KoHUjGlNE/
gpklCqLL5s2pquS1HHSmC3xBz76wrWhxbj+0HieXfx+7ieCPYGjmjV1xWZ0SYslT
n6TpBq6L//CgBg8mAYLWis1uiVDk49ne30KnD6s8Z3vUvPu5nuuefda+RuKhBuzE
ZO9RpXn7RgWU9i9lJ1hjTI6ooFji02L7mJpjEi6IPubznfPxq2+h9XjBzf0OChjp
qHB8k0iC9K6kwgwD5ZYa
=7ODp
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-ruby-extras-maintainers mailing list
Pkg-ruby-extras-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-ruby-extras-maintainers

Reply via email to