cblack requested changes to this revision.
cblack added a comment.
This revision now requires changes to proceed.


  Code looks good, bar one minor issue—instead of using global showOsdX 
functions, it would be more idiomatic to declare these functions on the OSD 
object itself. Other than that, this looks good.

INLINE COMMENTS

> main.qml:179
>  
> +    function showOsdVolume(text) {
> +        if (!Plasmoid.configuration.volumeOsd)

These functions would probably be better declared on the OSD object like so:

  VolumeOSD {
      id: osd
  
      function showVolume(text) {
          if (!Plasmoid.configuration.volumeOsd)
              return
          show(text)
      }
  }

REPOSITORY
  R115 Plasma Audio Volume Applet

REVISION DETAIL
  https://phabricator.kde.org/D28281

To: sgoth, #vdg, #plasma, broulik, ngraham, drosca, cblack
Cc: cblack, drosca, ngraham, plasma-devel, Orage, LeGast00n, The-Feren-OS-Dev, 
jraleigh, zachus, fbampaloukas, GB_2, ragreen, ZrenBot, himcesjf, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, ahiemstra, mart

Reply via email to