----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://git.reviewboard.kde.org/r/129101/#review99802 -----------------------------------------------------------
runners/windowedwidgets/windowedwidgetsrunner.cpp (line 107) <https://git.reviewboard.kde.org/r/129101/#comment67077> *Nit-picky:* If it's not a name, and other parts have a name, maybe we should rename this variable so that if this function ends up growing we don't have to worry about keeping this straight. shell/alternativeshelper.cpp (line 46) <https://git.reviewboard.kde.org/r/129101/#comment67078> *Very Minor:* Since we're changing the meaning of what we're returning now from the human-readable name to the plugin ID from metadata, now may be a good time to add some documentation to clarify what is being returned as the current plugin. - Michael Stemle On Oct. 5, 2016, 10:54 a.m., Aleix Pol Gonzalez wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://git.reviewboard.kde.org/r/129101/ > ----------------------------------------------------------- > > (Updated Oct. 5, 2016, 10:54 a.m.) > > > Review request for Plasma. > > > Repository: plasma-workspace > > > Description > ------- > > Reduces unnecessary castings. > > > Diffs > ----- > > applets/systemtray/systemtray.cpp e1cd610 > components/shellprivate/widgetexplorer/widgetexplorer.cpp c2b38a8 > plasma-windowed/plasmawindowedcorona.cpp fbacbf8 > runners/windowedwidgets/windowedwidgetsrunner.h 2294965 > runners/windowedwidgets/windowedwidgetsrunner.cpp 5ccbd27 > shell/alternativeshelper.cpp d0f5dfd > shell/containmentconfigview.cpp cec067e > shell/scripting/containment.cpp 6040e62 > shell/scripting/widget.cpp a651c2a > shell/shellcorona.cpp 1d08cd1 > > Diff: https://git.reviewboard.kde.org/r/129101/diff/ > > > Testing > ------- > > > Thanks, > > Aleix Pol Gonzalez > >