Forwarding these questions to the KWin and plasma-devel mailing lists.

-------- Forwarded Message --------
Subject: Re: kwin display issue on librem5
Date: Wed, 28 Feb 2018 12:59:39 -0700
From: Heather Ellsworth <>
CC:, Guido Günther <>, Nicole
Faerber <>

On 02/28/2018 11:53 AM, Heather Ellsworth wrote:
> Hi Roman,
> I've been working with Bhushan to get plasma mobile up and running on
> our prototype board and we're having an issue displaying the content.
> Attached is a photo (display_issue.jpg) showing the issue.
> We can force the software framebuffer (export KWIN_COMPOSE=Q) to get
> proper rendering (good_display_forced_framebuffer.jpg) but we don't want
> to force this.
> Guido pointed me to a helpful article:
> I tried the various tests suggested in that article and the nested setup
> works fine, there are no fatal errors, and trying on the tty worked ok.
> I should mention that in both the nested setup and trying on the tty,
> the mouse is not visible but is active because i can click the drop down
> menus and whatnot, I just can't see where the cursor is.

It is also worth mentioning that I also tried the following
troubleshooting steps:

1. No kwin_wayland session running

2. Get the dbus environment:
$ env | grep DBUS > /tmp/env
$ cat /tmp/env

3. In an ssh session to the board, export the vars:
$ export
$ export DBUS_SESSION_BUS_PID=1268

4. In a tty on the board, launch kwin_wayland:
$ kwin_wayland --drm plasma-phone

5. In an ssh session to the board:
$ qdbus org.kde.KWin /KWin supportInformation

The qdbus command pretty quickly causes the kwin_wayland to crash with a
seg fault:
Segementation fault (core dumped)d the Wayland compositor die?1-HP
W2371d/6CM2140D0D") "HDMI-A-1-HP W2371d/6CM2140D0D"ty

In journalctl, we see a piece of the stacktrace but not much:
Feb 28 19:34:05 pureos org.kde.ActivityManager[1268]: The Wayland
connection broke. Did the Wayland compositor die?
Feb 28 19:34:05 pureos org.kde.ActivityManager[1268]: Closing SQL
connection:  "kactivities_db_resources_3069980688_readwrite"
Feb 28 19:34:17 pureos systemd-coredump[1627]: Process 1572
(kwin_wayland) of user 1000 dumped core.

                                               Stack trace of thread 1572:
                                               #0  0x00000000b6e5a964
n/a (
Feb 28 19:34:18 pureos kernel: PM: Removing info for No Bus:sit0
Feb 28 19:34:18 pureos kernel: PM: Removing info for No Bus:lo
Feb 28 19:36:12 pureos kernel: wlcore: down

> That article also mentions running kwin on weird systems and I guess our
> dev board counts :)
> So my questions for you are:
> * Do you have any idea what could be missing or causing the
> display_issue.jpg that could be fixed by exporting KWIN_COMPOSE?
> * Do you know how to make the mouse cursor show up?
> Also if there's a better place to ask this (like a kwin irc or mailing
> list), I'm happy to redirect my questions. Once again, thanks for your
> time on this project.
> Cheers,
> Heather

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to