mherger wrote:
Spotty v1.3.0 is on its way to you!


I assume this version hasn't been published on github yet? Without

Hehe... yes, it's confusing. I usually refer to Spotty (uppercase) as the plugin. That code indeed is not on github (but in the plugin folder anyway).

When talking about the Rust part of it, I try to consistently call it the "spotty helper (application)" (spotty lowercase, like its filename). This spotty helper is what you'd find on github. And it follows a different versioning than the plugin.

looking at it, I cloned the repo and build it for FreeBSD, but I still
get version 0.6.2, the same as before.

The version distributed with the plugin still is 0.6.1. The only difference between the two is the client string used to connect to Spotify. They asked the librespot team to use a distinct string for every single build (like a build ID). I guess they want to be able to lock out a specific build in case it would cause problems. I merged that change in 0.6.2, but didn't go through the hassle of building new binaries yet.

BTW: How do these version numbers compare to 1.2.1 / 1.3.0?

They're totally independent. Except that the plugin's version number will increase whenever the helper's version number increases, even if the plugin code itself doesn't change.

--

Michael
_______________________________________________
plugins mailing list
plugins@lists.slimdevices.com
http://lists.slimdevices.com/mailman/listinfo/plugins

Reply via email to