Stuart Henderson wrote:
On 2026/09/10 16:42, Chris Billington wrote:
+EXTRACT_SUFX =         .tar.gz

not needed, this is the default

+SHA256 (3b12bc579b99932e3fe307ea1e44b8c1c6d1d5c9.tar.gz) = 
8F0xFe9bimf51zwRpZdy3EKaUdcFCZ1vuUFOq5VLb1g=

not a valid filename for distfiles

the patch to PLIST doesn't fully apply:

Hunk #22 failed at 1981.
1 out of 124 hunks failed--saving rejects to pkg/PLIST.rej


On 2026/09/10 03:07, Anthony J. Bentley wrote:
Chris Billington writes:
- upstream uses git submodules for pugixml, SingleApplication, and the
'elements' library. I have used the same pinned revisions in
SITES.xxx/DISTFILES.xxx as the upstream branch.

DIST_TUPLE would be a better fit for this.

yes, that would fix the 3b12bc5... filename too. (btw you can use GH_*
for the main file and DIST_TUPLE for submodules; portroach is likely to
cope better with that)

- The 'elements' user-submitted library (CC-BY-SA 3.0) is pinned against
a 9-month-old commit of the submodule repo.
Is it permissible to use a recent commit instead, since that would still
make a reproducible build but would include more recent items?

If doing so provides value and doesn't introduce incompatibility, then
sure.

agreed (in many cases there is a reason why upstream pins a particular
version, in some other cases there isn't, so do check)

- portcheck notes 3 Makefile lines longer than 80 chars, but it's not
easy to break them without sacrificing readability. Is that acceptable?

Yes.


Thanks, I'll revise using DIST_TUPLE for the submodules and re-submit. Plus figure out what happened in the PLIST diff.

Chris

Reply via email to