In databases/p5-DBIx-Class (and similar) I have added
MODULES += databases/mariadb

https://cvsweb.openbsd.org/ports/databases/p5-DBIx-Class

Last time I updated the port, it worked fine, but something has changed
in the way this should be set up and now mariadb fails to initialize. 

I tried commenting out the postgres parts, just to rule that out which
didn't help.  I'm not sure if this is the important line, and searching
doesn't help me figure out what I might need to do and there don't
appear to be any logs with further details in the location the output
suggested.

2026-09-16 16:54:29 0 [ERROR] InnoDB: Cannot map 
innodb_buffer_pool_size_max=8388608m

I tried increasing kern.maxlocksperuid to 20480 since the pkg-readme
suggested increasing it but not how high, also with the same failures.

Any suggestions what I'm doing wrong or what I need to adjust?

Most of my testing is on a sparc64 ldom (dmesg at the bottom), but I did
try on my amd64 laptop previously with no better results.

Currently waiting on a `make test` in databases/mariadb.

_ /usr/ports/pobj/p5-DBIx-Class-0.082843/test.log _

The files belonging to this database system will be owned by user "_pbuild".
This user must also own the server process.

The database cluster will be initialized with locale "C".
The default text search configuration will be set to "english".

Data page checksums are enabled.

creating directory /usr/ports/pobj/p5-DBIx-Class-0.082843/testdb-pg ... ok
creating subdirectories ... ok
selecting dynamic shared memory implementation ... posix
selecting default "max_connections" ... 100
selecting default "shared_buffers" ... 128MB
selecting default time zone ... US/Pacific
creating configuration files ... ok
running bootstrap script ... ok
performing post-bootstrap initialization ... ok

Sync to disk skipped.
The data directory might become corrupt if the operating system crashes.

Success. You can now start the database server using:

    /usr/local/bin/pg_ctl -D /usr/ports/pobj/p5-DBIx-Class-0.082843/testdb-pg 
-l logfile start

waiting for server to start.... done
server started
WARNING: The host 'zarniwoop.home.hewus.com' could not be looked up with 
/usr/local/bin/resolveip.
This probably means that your libc libraries are not 100 % compatible
with this binary MariaDB version. The MariaDB daemon, mariadbd, should work
normally with the exception that host name resolving will not work.
This means that you should use IP addresses instead of hostnames
when specifying MariaDB privileges !
Installing MariaDB/MySQL system tables in 
'/usr/ports/pobj/p5-DBIx-Class-0.082843/testdb-mariadb' ...
2026-09-16 16:54:29 0 [ERROR] InnoDB: Cannot map 
innodb_buffer_pool_size_max=8388608m
2026-09-16 16:54:29 0 [ERROR] InnoDB: Database creation was aborted with error 
Generic error. You may need to delete the ibdata1 file before trying to start 
up again.
2026-09-16 16:54:29 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE 
failed.
2026-09-16 16:54:29 0 [ERROR] Unknown/unsupported storage engine: InnoDB
2026-09-16 16:54:29 0 [ERROR] Aborting

Installation of system tables failed!  Examine the logs in
/usr/ports/pobj/p5-DBIx-Class-0.082843/testdb-mariadb for more information.

The problem could be conflicting information in an external
my.cnf files. You can ignore these by doing:

    shell> /usr/local/bin/mariadb-install-db --defaults-file=~/.my.cnf

You can also try to start the mariadbd daemon with:

    shell> /usr/local/libexec/mariadbd --skip-grant-tables --general-log &

and use the command line tool /usr/local/bin/mariadb
to connect to the mysql database and look at the grant tables:

    shell> /usr/local/bin/mariadb -u root mysql
    MariaDB> show tables;

Try '/usr/local/libexec/mariadbd --help' if you have problems with paths.  Using
--general-log gives you a log in 
/usr/ports/pobj/p5-DBIx-Class-0.082843/testdb-mariadb that may be helpful.

The latest information about mariadb-install-db is available at
https://mariadb.com/docs/server/clients-and-utilities/deployment-tools/mariadb-install-db
You can find the latest source at https://downloads.mariadb.org and
the MariaDB discuss email list at 
https://lists.mariadb.org/postorius/lists/discuss.lists.mariadb.org/

Please check all of the above before submitting a bug report
at https://mariadb.org/jira

2026-09-16 16:54:29 0 [Warning] Could not increase number of max_open_files to 
more than 512 (request: 32198)
2026-09-16 16:54:29 0 [Warning] Changed limits: max_open_files: 512  
max_connections: 82 (was 151)  table_cache: 200 (was 2000)
2026-09-16 16:54:29 0 [Note] Starting MariaDB 12.3.3-MariaDB source revision 
83e909fc2a0dbc394b4b683fb3fa2d7dcf26cc5e server_uid 
SaqNyNIEJAP7SLoNj81ADSn8f6c= as process 23045
2026-09-16 16:54:29 0 [Note] InnoDB: The first data file './ibdata1' did not 
exist. A new tablespace will be created!
2026-09-16 16:54:29 0 [Note] InnoDB: Compressed tables use zlib 1.3.2
2026-09-16 16:54:29 0 [Note] InnoDB: Number of transaction pools: 1
2026-09-16 16:54:29 0 [Note] InnoDB: Using generic crc32 instructions
2026-09-16 16:54:29 0 [ERROR] InnoDB: Cannot map 
innodb_buffer_pool_size_max=8388608m
2026-09-16 16:54:29 0 [ERROR] InnoDB: Database creation was aborted with error 
Generic error. You may need to delete the ibdata1 file before trying to start 
up again.
2026-09-16 16:54:29 0 [Note] InnoDB: Starting shutdown...
2026-09-16 16:54:29 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE 
failed.
2026-09-16 16:54:29 0 [Note] Plugin 'FEEDBACK' is disabled.
2026-09-16 16:54:29 0 [Note] Plugin 'wsrep-provider' is disabled.
2026-09-16 16:54:29 0 [ERROR] Unknown/unsupported storage engine: InnoDB
2026-09-16 16:54:29 0 [ERROR] Aborting
mariadbd didn't start
/bin/sh: kill: 23045: No such process
waiting for server to shut down.... done
server stopped
*** Error 1 in . (Makefile:88 'do-test')

_ /var/run/dmesg.boot _

console is /virtual-devices@100/console@1
Copyright (c) 1982, 1986, 1989, 1991, 1993
        The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2026 OpenBSD. All rights reserved.  https://www.OpenBSD.org

OpenBSD 8.0-beta (GENERIC.MP) #31: Tue Sep 15 16:33:25 MDT 2026
    [email protected]:/usr/src/sys/arch/sparc64/compile/GENERIC.MP
real mem = 17179869184 (16384MB)
avail mem = 16849731584 (16069MB)
random: good seed from bootblocks
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root: SPARC T4-1
cpu0 at mainbus0: SPARC-T4 (rev 0.0) @ 2847.862 MHz
cpu1 at mainbus0: SPARC-T4 (rev 0.0) @ 2847.862 MHz
cpu2 at mainbus0: SPARC-T4 (rev 0.0) @ 2847.862 MHz
cpu3 at mainbus0: SPARC-T4 (rev 0.0) @ 2847.862 MHz
cpu4 at mainbus0: SPARC-T4 (rev 0.0) @ 2847.862 MHz
cpu5 at mainbus0: SPARC-T4 (rev 0.0) @ 2847.862 MHz
cpu6 at mainbus0: SPARC-T4 (rev 0.0) @ 2847.862 MHz
cpu7 at mainbus0: SPARC-T4 (rev 0.0) @ 2847.862 MHz
cpu8 at mainbus0: SPARC-T4 (rev 0.0) @ 2847.862 MHz
cpu9 at mainbus0: SPARC-T4 (rev 0.0) @ 2847.862 MHz
cpu10 at mainbus0: SPARC-T4 (rev 0.0) @ 2847.862 MHz
cpu11 at mainbus0: SPARC-T4 (rev 0.0) @ 2847.862 MHz
cpu12 at mainbus0: SPARC-T4 (rev 0.0) @ 2847.862 MHz
cpu13 at mainbus0: SPARC-T4 (rev 0.0) @ 2847.862 MHz
cpu14 at mainbus0: SPARC-T4 (rev 0.0) @ 2847.862 MHz
cpu15 at mainbus0: SPARC-T4 (rev 0.0) @ 2847.862 MHz
"reboot-memory" at mainbus0 not configured
vbus0 at mainbus0
"flashprom" at vbus0 not configured
vrng0 at vbus0
cbus0 at vbus0
vdsk0 at cbus0 chan 0x2: ivec 0x4, 0x5
scsibus1 at vdsk0: 1 targets
sd0 at scsibus1 targ 0 lun 0: <SUN, Virtual Disk, 1.1>
sd0: 16384MB, 512 bytes/sector, 33554432 sectors
vdsk1 at cbus0 chan 0x3: ivec 0x6, 0x7
scsibus2 at vdsk1: 1 targets
sd1 at scsibus2 targ 0 lun 0: <SUN, Virtual Disk, 1.1>
sd1: 32768MB, 512 bytes/sector, 67108864 sectors
vnet0 at cbus0 chan 0x4: ivec 0x8, 0x9, address 00:14:4f:f9:2e:01
vcons0 at vbus0: ivec 0x8011: console
vrtc0 at vbus0
vpci0 at mainbus0: bus 0 to 255, dvma map 80000000-ffffffff
pci0 at vpci0
ppb0 at pci0 dev 1 function 0 "Sun SDIO PCIE" rev 0x01
pci1 at ppb0 bus 1
ppb1 at pci1 dev 0 function 0 "Sun SDIO PCIE" rev 0x01
pci2 at ppb1 bus 2
ppb2 at pci2 dev 6 function 0 "Sun SDIO PCIE" rev 0x01
pci3 at ppb2 bus 5
nvme0 at pci3 dev 0 function 0 "SK hynix BC501" rev 0x00: msix, NVMe 1.2
nvme0: HFM128GDHTNG-8510B, firmware 80010C00, serial NJ91N546211201G69
scsibus3 at nvme0: 2 targets, initiator 0
sd2 at scsibus3 targ 1 lun 0: <NVMe, HFM128GDHTNG-851, 8001>
sd2: 122104MB, 512 bytes/sector, 250069680 sectors
vscsi0 at root
scsibus4 at vscsi0: 256 targets
softraid0 at root
scsibus5 at softraid0: 256 targets
bootpath: /virtual-devices@100,0/channel-devices@200,0/disk@0,0
root on sd0a (932997cd478cdeb7.a) swap on sd0b dump on sd0b

Reply via email to