On Mon, Oct 17, 2016 at 06:58:26PM +0200, Jasper Lievisse Adriaanse wrote:
> On Mon, Oct 17, 2016 at 02:59:43PM +0200, Sebastien Marie wrote:
> > Hi,
> > 
> > With the latest update of ansible (ansible-2.1.2.0->2.1.2.0p3), I
> > experiment failure in the use of `openbsd_pkg' module.
> > 
> > The exception occurs when specifying a package name without version or
> > branch (like juste "sysclean"). The code will assume branch syntax and
> > will fail at extracting branch information after '%'.
> > 
> 
> Does this also happen when you remove the two '-z' parts of the local patch we
> carry for ansible? I don't have a CVS tree around right now to provide you 
> with
> a patch to apply.
> 

Removing -z will not be enough. The openbsd_pkg.py file from the
extracted tar ball is missing a lot of branch related changes from
upstream.

This particular problem is a result of adding the last iteration of
branch-syntax fixes without the previous plumbing.

Doing a diff -u between a "make extract" version of openbsd_pkg.py and
an upstream version from git shows quite a bit of changes that are
missing.

-- 
Patrik Lundin

Reply via email to