Hi Alex,

You should be able to see more details in /var/log/mail.log. postfix is pretty 
verbose in the logs. Try sending a test mail and observe the log file. Revert 
with the relevant entry to see what happened.

On September 21, 2016 12:30:27 AM EEST, Alex Hall <ah...@autodist.com> wrote:
>Hello list,
>A very quick intro first. I work for a company that uses all virtual
>servers, a change we recently adopted. I'm setting up Request Tracker
>internal use, which requires a Linux system to run. Thus, I'm learning
>about Linux and all of RT's required packages at the same time. I'm
>comfortable on the command line, and know the basics of Bash, but I'm
>expert. I'm running Debian 8, Postfix, Fetchmail, and Request Tracker,
>with the latest updates as of today. Our company uses Google Apps to
>mail for our domain, so my address (ah...@domain.com) is essentially a
>Gmail address. That'll be important in a minute.
>Now, to why I'm sending this email. To make sure RT was going to work,
>set it up on a Digital Ocean server, also Debian, and was able to get
>things working pretty easily. The bit that matters here is that I was
>to get Postfix working; it would send out emails as Request Tracker
>told it
>to, and everyone received them with no problem. Since that worked, my
>told me to move it to a virtual server on our network, which I did.
>was two weeks ago, and since that move, not one email has been received
>anyone in the company from that server.
>From all I can tell, Postfix is doing it right: it sends the emails,
>and so
>long as the recipient is *not* @domain.com, the message is delivered.
>If it
>*is* @domain.com, the message silently disappears. This holds true
>I use Gmail or Mandrill as the relay for Postfix--non-company addresses
>work, company ones do not. The Mandrill logs seem to indicate that my
>messages lack a sender, which suggests that my envelope may be
>thus causing Gmail to flip out when it sees them.
>What I hope people on this list can offer are suggestions regarding
>what I
>can do to fix this. Why my Digital Ocean server worked perfectly, and
>internal, virtual server doesn't is the biggest mystery. I don't know
>to tell Postfix to let me see the full details of outgoing messages so
>can examine them. Oh, speaking of outgoing messages, RT isn't the only
>whose messages run into this problem. The following command encounters
>too, despite my extra headers:
>echo "test" | mail -s "test" -a "from: Postfix
>-a "reply-to: Postfix <validusern...@domain.com>" ah...@domain.com
>My server seems to have the right name, too. The result of 'hostname'
>'myServerName', and 'hostname -f' is 'myservern...@domain.com'. I have
>aliases set up, but neither did I on the Digital Ocean server; this
>is meant for RT, not to send out its own emails, so I don't think I
>aliases. (?)
>Bottom line: on one server, everything was great. On my company's
>server, with the same configuration, packages, and settings, mail sent
>is silently discarded by Gmail when delivered to anyone on the
>domain. I must be missing required envelope details somewhere, but I
>know where. I'm hoping someone can suggest where I can look, and what I
>try, to fix this. Please let me know what additional information is
>required to troubleshoot this problem. Thank you in advance.
>Alex Hall
>Automatic Distributors, IT department

Sent from my Android device with K-9 Mail. Please excuse my brevity.

Reply via email to