Hi Regina,

Sorry for the late response, I did not see this email before:

On Wed, 2017-07-26 at 01:11 -0400, Regina Obe wrote:
> Why can't you support 10 in 9.6?
> 
> If people install 10 in 9.6, they can then pg_upgrade to 10.

Do you mean 2.4, not 10?

> I'm hesitant to support 10 in 2.3 because that would mean we have to support
> it for the life of 10 and I already made enough changes in 2.4 for 10 that it
> leaves me a bit hesitant to risk back-porting those changes to 2.3.

The history is here:

https://bugzilla.redhat.com/show_bug.cgi?id=1055293


So, here is the scenario:

* There is a PostGIS 2.3 and Postgres 9.6 user, who want to upgrade to Postgres
10, and PostGIS 2.4.

* To perform pg_upgrade, they need 2.3 so file as well in 2.4 installation (see
bug report)

* We fail here, as 2.3 cannot be built against v10.

Regards, 

-- 
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

Attachment: signature.asc
Description: This is a digitally signed message part

_______________________________________________
postgis-users mailing list
postgis-users@lists.osgeo.org
https://lists.osgeo.org/mailman/listinfo/postgis-users

Reply via email to