-- Fixed a bug that meant last argument sent to functions handling
mouse actions was wrong (it was always the handle to the target
dialog, not the handle to target control, if any)
-- Fixed a bug that meant static variables preceded by the evaluation
marker wouldn't be recognised.
-- The "imgspacing" style for buttons can be negative; that will
overlap graphic and text, which may work if the graphic has a
substantial transparent background.
-- Added internal fixes in way the window receiving a mouse action is
identified; should be faster and more reliable, but I bet change won't
be observable.
-- get_last_clicked now returns the handle to any the last control or
dialog which responded to a user action, not just funny mouse actions
like right-click.
-- scintilla, rich text edit and plain edit controls can now be
assigned a <right_click_command> with define, define_control or
set_response, overriding the built-in context menus (or, in the case
of rich text edit controls, the default context menu the plugin supplies).
-- I forgot to document the get_value <type>s "selectlen", and
"selected" or "select" for scintilla, rich text edit and plain edit
controls.
-- Added the get_value <type>"type" for all controls
-- Changed name of button style equivalent to BS_FLAT from
"buttonflat" to "flat".
-- I'm working on interpreting "flat" button style to mean the fancy
kind of flat button that gets a border when you hover over it. Work
in progress, not yet done and I may add a new style ("cool" ?)
that's different from plain old flat buttons.
-- Slowly rewriting regex scripts to use context menus on edit boxes
instead of "Options" buttons.