Hello,

I've recently moved from CentOS to FreeBSD and am having issues
starting prosody with use_libevent=true. I'm using luajit-2.0.3 (same
behavior with lua5.1 though), libevent2-2.0.21_2 and master of luaevent
(there isn't a port for it, so I thought of going with the latest if
I'm compiling it anyway).

All tests for libevent run successfully, but when I start prosody, all
I get is:

Sep 09 02:02:55 general info    Hello and welcome to Prosody version 0.9.4
Sep 09 02:02:55 general info    Prosody is using the kqueue backend for 
connection handling
Sep 09 02:02:55 hostmanager     debug   Activated host: irc.nth.ro
Sep 09 02:02:55 portmanager     debug   No active service for component, 
activating...
Sep 09 02:02:55 socket  debug   creating server interface... 
Sep 09 02:02:55 socket  debug   new server created with id: table: 0x801ddd600 
Sep 09 02:02:55 portmanager     debug   Added listening service component to 
[192.168.214.250]:5347
Sep 09 02:02:55 portmanager     info    Activated service 'component' on 
[192.168.214.250]:5347
Sep 09 02:02:55 portmanager     debug   No active service for s2s, activating...
Sep 09 02:02:55 socket  debug   creating server interface... 
Sep 09 02:02:55 socket  debug   new server created with id: table: 0x801df1080 
Sep 09 02:02:55 portmanager     debug   Added listening service s2s to 
[192.168.214.250]:5269
Sep 09 02:02:55 portmanager     info    Activated service 's2s' on 
[192.168.214.250]:5269
Sep 09 02:02:55 hostmanager     debug   Activated host: facebook.nth.ro
Sep 09 02:02:55 hostmanager     debug   Activated host: proxy.nth.ro
Sep 09 02:02:55 portmanager     debug   No active service for proxy65, 
activating...
Sep 09 02:02:55 socket  debug   creating server interface... 
Sep 09 02:02:55 socket  debug   new server created with id: table: 0x801e37700 
Sep 09 02:02:55 portmanager     debug   Added listening service proxy65 to 
[192.168.214.250]:5001
Sep 09 02:02:55 portmanager     info    Activated service 'proxy65' on 
[192.168.214.250]:5001
Sep 09 02:02:55 hostmanager     debug   Activated host: yahoo.nth.ro
Sep 09 02:02:55 hostmanager     debug   Activated host: rooms.nth.ro
Sep 09 02:02:55 datamanager     debug   Assuming empty persistent storage 
('cannot open /usr/local/var/lib/prosody/rooms%2enth%2ero/persistent.dat: No 
such file or directory') for user: n...@rooms.nth.ro
Sep 09 02:02:55 hostmanager     debug   Activated host: nth.ro
Sep 09 02:02:55 nth.ro:auth_internal_plain      debug   initializing 
internal_plain authentication provider for host 'nth.ro'
Sep 09 02:02:55 usermanager     debug   host 'nth.ro' now set to use user 
provider 'internal_plain'
Sep 09 02:02:55 portmanager     debug   No active service for c2s, activating...
Sep 09 02:02:55 socket  debug   creating server interface... 
Sep 09 02:02:55 socket  debug   new server created with id: table: 0x801fc39c0 
Sep 09 02:02:55 portmanager     debug   Added listening service c2s to 
[192.168.214.250]:5222
Sep 09 02:02:55 portmanager     info    Activated service 'c2s' on 
[192.168.214.250]:5222
Sep 09 02:02:55 portmanager     debug   No active service for legacy_ssl, 
activating...
Sep 09 02:02:55 portmanager     info    Activated service 'legacy_ssl' on no 
ports
Sep 09 02:02:55 mod_posix       info    Prosody is about to detach from the 
console, disabling further console output
Sep 09 02:02:55 mod_posix       info    Successfully daemonized to PID 8529
Sep 09 02:02:55 general info    Shutting down...
Sep 09 02:02:55 general info    Shutdown status: Cleaning up
Sep 09 02:02:55 general info    Shutdown complete


It seems that it's just dropping out of the main loop (no events are
being registered) ? Without libevent enabled, prosody works just as
awesome as ever. I've then tried the last release of luaevent (0.4.3),
but still without success. Searching a bit online, I found the
same issue reported a while ago, with no resolve:
https://code.google.com/p/lxmppd/issues/detail?id=412
and nothing else.

Any hints on why this is not working? What more information is
needed to help debug this? Or am I just missing something obvious here?


Regards,

-- 
Theo

-- 
You received this message because you are subscribed to the Google Groups 
"prosody-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to prosody-dev+unsubscr...@googlegroups.com.
To post to this group, send email to prosody-dev@googlegroups.com.
Visit this group at http://groups.google.com/group/prosody-dev.
For more options, visit https://groups.google.com/d/optout.

Reply via email to