On 2014-10-14 15:15, David Millman wrote:
> I believe that the brew install on http://prosody.im/download/start has
> a small bug.  When running the installer, I get the error message:
> 
> Error: No available formula for lua51 (dependency of prosody)
> 
> After poking around for a few minutes, I installed lua and checked the
> version;
> 
>   $ brew install lua
>   ... install successfully ...
>   $ brew list --versions lua
>   lua 5.1.5
> 
> It seems like that satisfies the dependency, so I patched the script:
> 
>   $ diff prosody.rb prosody.dlm-patch.rb
>   14c14
>   <   depends_on "lua51"
>   ---
>   >   depends_on "lua"
> 
> I tried installing again and this time it installed successfully.

Didn't they make "lua" be Lua 5.2 recently?  Because someone had the
very inverse problem recently, which is why it was changed from "lua" to
"lua51".  Maybe try updating your brew?

--
Regards,
Kim "Zash" Alvefur

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to