On 2/20/17 9:26 AM, Kim Alvefur wrote:
On Thu, Dec 29, 2016 at 10:25:00AM +0100, Victor Seva wrote:
This is the work I've done at mod_mam[0] in order to support the latest
version of XEP-0313

The module now supports both versions "urn:xmpp:mam:0" and
"urn:xmpp:mam:1"

The communtiy version of mod_mam now supports every version of XEP-0313
between 0.3 (urn:xmpp:mam:0) and 0.6 (..:mam:2). Meanwhile, the 0.10
version supports only the latest (0.6 or :2). Some changes from the 0.10
version has also been merged back in.

Attached patch from hg export output.

Thanks, however I did not use your patch directly. Some inspiration may
have been drawn from it however.


Pardon my ignorance, but is there an easy way to tell whether I have the community or built-in version of mod_mam enabled? I'm running the latest 0.10 nightly and I also have Prosody configured to use the current hg "working copy" (for the lack of the appropriate word) of the modules repo.

When I ask Pidgin to list the loaded modules, it shows mam and mam_archive loaded.

I see this in the config file:

> -- Plugins are searched in all the specified paths in order, and finally
> -- checked in the default plugin directory.

which I take to mean that modules of the same name will be loaded first from the optional path and then lastly the defaults.

--
You received this message because you are subscribed to the Google Groups 
"prosody-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to prosody-dev+unsubscr...@googlegroups.com.
To post to this group, send email to prosody-dev@googlegroups.com.
Visit this group at https://groups.google.com/group/prosody-dev.
For more options, visit https://groups.google.com/d/optout.

Reply via email to