On 10/24/2010 5:10 PM, Thomas Heller wrote:
On Sun, Oct 24, 2010 at 9:59 AM, Joel de Guzman
<j...@boost-consulting.com>  wrote:
On 10/24/2010 1:16 PM, Eric Niebler wrote:


Now, what to call the traveral/algorithm/action/on thingy. None of those
feel right. Maybe if I describe in words what it does, someone can come
up with a good name. Given a Proto grammar that has been built with
named rules, and a set of actions that can be indexed with those rules,
it creates a Proto algorithm. The traversal is fixed, the actions can
float. It's called<insert good name here>.

Actor

  std::cout<<  actor<char_terminal, my_actions>()(a)<<  "\n"; // printing
char

:-)

Cool, then we'd need some new name for phoenix, hmn?

Yeah: "lambda"

Heh, I'm too emotionally tied to the name "phoenix" but I won't mind
if it eventually becomes a sub-title for the sake of the "greater good".

I like:
      apply
      actor
      algorithm
      traverse

Am I the only one thinking that "actor" should be more a part of proto than
phoenix? I'd love to use such a generic extension mechanism for Spirit too,
for example.

Regards,
--
Joel de Guzman
http://www.boostpro.com
http://spirit.sf.net



_______________________________________________
proto mailing list
proto@lists.boost.org
http://lists.boost.org/mailman/listinfo.cgi/proto

Reply via email to