thanks for the heads up, upgrading to 2.1.0 noticed that the c++ example now
requires -lpthread, once I compile my application it will need to know about
pthread also.

is there a set of release notes that i need to be aware of, and also are
there any patches against 2.1.0 that I may need, if so how do i find out
what they are?

will "make uninstall" take out all flavors of protocol buffer libraries (I
used make install on top of a prior install and would like to remove the
older version)

thanks


On Wed, Jul 29, 2009 at 2:22 PM, Kenton Varda <ken...@google.com> wrote:

> On Wed, Jul 29, 2009 at 4:14 AM, Sushil Shelly <skshe...@gmail.com> wrote:
>
>> I need to upgrade a linux installation of protocol buffers. I have 2.0.3
>> and need to move up to use 2.1.0 - is there a set procedure to do this?
>>
>
> You can just install it normally.  You may also want to recompile any apps
> based on it, but this is not strictly necessary.  Although different
> versions of libprotobuf.so are not binary-compatible (C++ sadly makes
> compatibility too difficult to achieve), we use libtool's version numbering
> to make sure that binary-incompatible versions of libprotobuf do not
> overwrite each other.  So, any binaries you compiled against the old version
> will continue to use the old version at runtime.
> If you want to uninstall the old version, then run "make uninstall" from
> the same directory where you you ran "make install" to install it.
>
> BTW, 2.2.0 will be out in the next week or two.
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Protocol Buffers" group.
To post to this group, send email to protobuf@googlegroups.com
To unsubscribe from this group, send email to 
protobuf+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/protobuf?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to