Seems to be working here, and passed in CI on all the runs from
commits yesterday:
https://builds.apache.org/view/M-R/view/Qpid/job/Qpid-proton-j/

NoSuchMethodError is an interesting one. I think code in that area
will have changed with Bozo's recent commit, but the only likely way
that should cause issues is if something stale is in the loop,
otherwise I'd expect compilation issues. I tend only to see
NoSuchMethodError when running Eclipse and MAven (CLI) builds in the
same tree at the same time and they can trip each other up. Other than
that, not really.

Robbie

On 19 August 2015 at 16:54, Gordon Sim <g...@redhat.com> wrote:
> The proton-j tests appear to be failing on master for me, even for a
> completely clean build with all the stuff that proton-j generates in the
> source tree removed as well:
>
>> Leaked an instance of
>> 'sun.nio.ch.ServerSocketChannelImpl[/127.0.0.1:36861]' from:
>> java.lang.Exception
>>         at
>> org.apache.qpid.proton.reactor.impl.LeakTestReactor$TestIO.serverSocketChannel(LeakTestReactor.java:64)
>>         at
>> org.apache.qpid.proton.reactor.impl.AcceptorImpl.<init>(AcceptorImpl.java:89)
>>         at
>> org.apache.qpid.proton.reactor.impl.ReactorImpl.acceptor(ReactorImpl.java:429)
>>         at
>> org.apache.qpid.proton.reactor.ReactorTest.connect(ReactorTest.java:235)
>
>
>
>> Tests run: 49, Failures: 11, Errors: 22, Skipped: 0, Time elapsed: 0.198
>> sec <<< FAILURE!
>> connect[0](org.apache.qpid.proton.reactor.ReactorTest)  Time elapsed:
>> 0.008 sec  <<< ERROR!
>> java.lang.NoSuchMethodError:
>> org.apache.qpid.proton.engine.impl.CollectorImpl.put(Lorg/apache/qpid/proton/engine/Event$Type;Ljava/lang/Object;)Lorg/apache/qpid/proton/engine/impl/EventImpl;
>>         at
>> org.apache.qpid.proton.engine.impl.ConnectionImpl.put(ConnectionImpl.java:644)
>>         at
>> org.apache.qpid.proton.engine.impl.ConnectionImpl.collect(ConnectionImpl.java:626)
>>         at
>> org.apache.qpid.proton.reactor.impl.ReactorImpl.connection(ReactorImpl.java:416)
>>         at
>> org.apache.qpid.proton.reactor.ReactorTest.connect(ReactorTest.java:258)
>
>
>
>> barfOnLink[1](org.apache.qpid.proton.reactor.ReactorTest)  Time elapsed:
>> 0.008 sec  <<< FAILURE!
>> junit.framework.AssertionFailedError: Resources leaked
>>         at
>> org.apache.qpid.proton.reactor.impl.LeakTestReactor$TestIO.assertNoLeaks(LeakTestReactor.java:101)
>>         at
>> org.apache.qpid.proton.reactor.impl.LeakTestReactor.assertNoLeaks(LeakTestReactor.java:115)
>>         at
>> org.apache.qpid.proton.reactor.ReactorTest.checkForLeaks(ReactorTest.java:96)
>>         at
>> org.apache.qpid.proton.reactor.ReactorTest.after(ReactorTest.java:102)
>
>
> plus many, many more similar to these. Anyone else seeing this?

Reply via email to