I would definitely second the nomination of a name that actually  
means something, like 'setAttribute' or similar. But then I'm a fan  
of self documenting function names - even when they're long and  
include all the letters in words.

On Aug 15, 2007, at 8:58 AM, Ken Snyder wrote:

> Tom Gregory wrote:
>> ...
>> apply: function(iterator, attribute, value) {
>>     return this.map(function(item, index) {
>>        item[attribute] = value;
>>     });
>> },
>> ...
> I've run into a need for this as well.  I'd vote for including it  
> under
> a name 'setAll' or 'setEach'.
> Or, what is the exact opposite of pluck? Pin? Place? Affix?  :P
> - Ken Snyder

You received this message because you are subscribed to the Google Groups 
"Prototype: Core" group.
To post to this group, send email to prototype-core@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 

Reply via email to