On 8/30/07, Mislav Marohnić <[EMAIL PROTECTED]> wrote:
> On 8/31/07, [EMAIL PROTECTED] <[EMAIL PROTECTED]> wrote:
> > and is there any reason not to use String.replace([regexp], function()
> > {} ) for a large part of the functions implemented by iterating
> > through arrays? this can be blazingly fast even for complicated regex
> > as long as they are precompiled, and the code is far more readable and
> > compact (i.e. camelization, templating, etc etc )
>
> Nothing prevents you from submitting patches. We will welcome optimizations
> for camelization, templating and related stuff.
As discussed in
http://redhanded.hobix.com/inspect/showingPerfectTime.html
String.prototype.replace with a callback is broken in Safari (at least
up until v2).
Best,
Nicolas
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups
"Prototype: Core" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at
http://groups.google.com/group/prototype-core?hl=en
-~----------~----~----~----~------~----~------~--~---