2009/9/25 T.J. Crowder <t...@crowdersoftware.com>:
>
> Andrew,
>
> Make sense.  Shouldn't that be Function.empty and Function.k, though,
> to follow our naming rules?  And perhaps Function.k should have a more
> meaningful name.
>
> -- T.J.
>
> On Sep 25, 4:20 am, Andrew Dupont <goo...@andrewdupont.net> wrote:
>> Unless anyone has serious objections, or has a better idea, I'm going
>> to add these as aliases of `Prototype.emptyFunction` and
>> `Prototype.K`, respectively. They belong better there, since in theory
>> the `Prototype` namespace is for internal stuff, not for stuff that
>> has value to end-user developers.
>>
>> Cheers,
>> Andrew
> >
>

As f(x) => x, f is an identity function.

So, maybe

Function.identity(x) { return x; }

Hmm, whilst technically correct, the term "identity" may not be what
people are used to.

Maybe Function.AsIs() ?

-- 
-----
Richard Quadling
"Standing on the shoulders of some very clever giants!"
EE : http://www.experts-exchange.com/M_248814.html
Zend Certified Engineer : http://zend.com/zce.php?c=ZEND002498&r=213474731
ZOPA : http://uk.zopa.com/member/RQuadling

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Prototype: Core" group.
To post to this group, send email to prototype-core@googlegroups.com
To unsubscribe from this group, send email to 
prototype-core-unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/prototype-core?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to