Function.empty and Function.identity get my vote.

However, does this mean Prototype.EMPTY and Prototype.K are being
deprecated?  I ask because I generally dislike aliases in APIs.  Unless they
are used as part of the deprecation process, they are usually more trouble
than they're worth.  They make code harder to read and share, developers get
into silly quibbles as to which is better, etc.  In short, they're annoying
- it's better if the framework developers make it clear what the preferred
name is, and eventually deprecate the non-preferred ones.

My $.02.

- rwk


On Fri, Sep 25, 2009 at 6:19 AM, T.J. Crowder <t...@crowdersoftware.com>wrote:

>
> We could _so_ overcomplicate this... ;-)
>
> On Sep 25, 1:29 pm, Jim Higson <j...@wikizzle.org> wrote:
> > On Friday 25 September 2009 13:08:57 Rick Waldron wrote:
> >
> > > On the subject of end developer confusion, I'd like to make a
> suggestion
> > > regarding the naming...
> >
> > > Function.emptyFn
> > > Function.returnFn
> >
> > > Because they say exactly what they are. This is how I've named
> (almost...
> > > $.function.emptyFn() and $.function.returnFn() ) the exact same
> > > functionality in the Pollen.JS library (for use within a new Worker() )
> >
> > I'd say returnFn sounds like a function which returns a function.
> >
> > --
> > Jim
> > my wiki ajaxification thing:http://wikizzle.org
> > my blog:http://jimhigson.blogspot.com/
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Prototype: Core" group.
To post to this group, send email to prototype-core@googlegroups.com
To unsubscribe from this group, send email to 
prototype-core-unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/prototype-core?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to