Hi,

Your posting back is much appreciated! People rarely take the time and
just leave things dangling.

Thanks!
--
T.J. Crowder
Independent Software Consultant
tj / crowder software / com
www.crowdersoftware.com


On Apr 22, 9:58 am, epoch <williescho...@gmail.com> wrote:
> Hi Again
>
> I have finally completed my debugging session and found the problem,
> the problem was the NTLM authentication, seems like IE
> needs a handshake from the server when it sends the blank request, as
> soon as i send the handshake, the original Ajax.Request gets executed
> again automatically
>
> So consider this question closed, hope this thread helps other people
> aswell.
>
> Cheers everyone
>
> On Apr 21, 9:58 am, epoch <williescho...@gmail.com> wrote:
>
>
>
>
>
> > Hi Again
>
> > Just an update, i have done further debugging and have finally found
> > the problem after looking at the request headers with fiddler.
> > the problem is that our system uses LDAP, the server is challenged
> > with WWW-Authenticate at the login page only once.
>
> > now only in internet explorer if I wait more than 30 seconds IE seems
> > to add an "Authorization" header to the Prototype request and drops
> > the query string.
> > So in other words i do not think that this is a prototype error but
> > rather a server side error, i will now try to remove that header
> > before the request.
>
> > If anybody else has any input, please share.
>
> > Thanks guys!
>
> > On Apr 20, 4:12 pm, epoch <williescho...@gmail.com> wrote:
>
> > > Hi Guys
>
> > > This is my first post. firstly i would like to congratulate everyone
> > > who helped make prototype awesome!
>
> > > Secondly I have a very strange problem, I would consider myself very
> > > well versed with Prototype (been using it more than one year)
>
> > > It appears my ajax request's stop executing after 20-30 seconds of the
> > > previous ajax request (not page load).
> > > I have debugged this and found out that prototype does indeed have the
> > > parameters and sends it successfully (without errors), but my server
> > > side handler (a jsp) returns all request.getParameter("variable")
> > > calls null.
>
> > > if I then start clicking the button that makes the ajax request
> > > quickly in succession, it starts receiving the parameters again?
>
> > > this only happens when using the post method which in turn sends using
> > > xmlhttp.send(postBody). also if i manually append the parameters to
> > > the url and use xmlhttp.send(null), everything works as expected
>
> > > This only affects internet explorer, other browsers work perfectly.
> > > this made me think that the underlying XMLHttpRequest object has a
> > > problem.
>
> > > Unfortuntally i do not have the neccesarry skill to continue debugging
> > > further. Can anyone please assist me with this?
>
> > > here is a code example of how I can create the problem automatically
> > > (with IE) :
>
> > >             var xu = function(o) {
> > >                 new Ajax.Request('AjaxComponentServlet', {
> > >                     parameters: {
> > >                         action: 'TESTER ' + o + ' ' + new Date(),
> > >                         random: Math.random()
> > >                     },
> > >                     method: 'post'
> > >                 });
> > >                 window.setTimeout('xu(' + (o + 1) + ')', (o*10000));
> > >             }
>
> > >             Event.observe(window, 'load', function() {
> > >                 window.setTimeout('xu(1)', 1 * (1000 * 10));
> > >             });
>
> > > --
> > > You received this message because you are subscribed to the Google Groups 
> > > "Prototype & script.aculo.us" group.
> > > To post to this group, send email to 
> > > prototype-scriptacul...@googlegroups.com.
> > > To unsubscribe from this group, send email to 
> > > prototype-scriptaculous+unsubscr...@googlegroups.com.
> > > For more options, visit this group 
> > > athttp://groups.google.com/group/prototype-scriptaculous?hl=en.
>
> > --
> > You received this message because you are subscribed to the Google Groups 
> > "Prototype & script.aculo.us" group.
> > To post to this group, send email to 
> > prototype-scriptacul...@googlegroups.com.
> > To unsubscribe from this group, send email to 
> > prototype-scriptaculous+unsubscr...@googlegroups.com.
> > For more options, visit this group 
> > athttp://groups.google.com/group/prototype-scriptaculous?hl=en.
>
> --
> You received this message because you are subscribed to the Google Groups 
> "Prototype & script.aculo.us" group.
> To post to this group, send email to prototype-scriptacul...@googlegroups.com.
> To unsubscribe from this group, send email to 
> prototype-scriptaculous+unsubscr...@googlegroups.com.
> For more options, visit this group 
> athttp://groups.google.com/group/prototype-scriptaculous?hl=en.

-- 
You received this message because you are subscribed to the Google Groups 
"Prototype & script.aculo.us" group.
To post to this group, send email to prototype-scriptacul...@googlegroups.com.
To unsubscribe from this group, send email to 
prototype-scriptaculous+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/prototype-scriptaculous?hl=en.

Reply via email to