Resolved it, I just copied your files from master but I didn't check the 
ptxdist configuration, 
in which the e2fsprogs package was still selected although I deleted it from 
(the 1.99.20 version of and the build failed cause ptx was 
getting the libblkid 
from util-linux-ng (master version) but still tried to build e2fsprogs libblkid 
and those two
Once I had removed the e2fsprogs package from the ptxdist configuration, then 
the build
worked like a charm.
By 'commenting support' I meant that due to the problem described above I 
ptxdist was executing commented lines in rules/ (the 1.99.20 
you are probably confused with what i said now, but what I did is the following:
        1. Changed util-linux-ng.make, but didn't changed the
        2. Tried to build, didn't work.
        3. Thought that the commented lines in were executing
        because they contained E2FSPROGS but I commented them out, so
        I didn't know why ptxdist built e2fsprogs, without aksing me.
        4. Changed, tried to build, conflict between 
        and e2fsprogs showed up.
        5. Chenged ptxdist configuration, disabled e2fsprogs, then it worked.
Lijep pozdrav / Best regards
Jakov Šimunić

On Tue, Jun 12, 2018 at 07:14:35AM +0000, Jakov Simunic wrote:
> Yes, you are right, it is
> Btw, still haven't resolved it, somehow ptxdist also tries to build 
> e2fsprogs, although i don't see it selected in the files I modified 
> (it is commented the same way as in current ptx master), does ptx 
> 1.99.20 even have commenting support?

A long time ago libblkid was provided by e2fsprogs, so maybe you need to select 
this instead. I'm not sure what you mean by 'commenting support'.


Pengutronix e.K.                           |                             |
Industrial Linux Solutions                 |  |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |

ptxdist mailing list
ptxdist mailing list

Reply via email to