Of possible value in this thread, RFC 7719 has a bunch of definitions of DNS 
terms. Here's what it says about "wildcard":

   Wildcard:  [RFC1034] defined "wildcard", but in a way that turned out
      to be confusing to implementers.  Special treatment is given to
      RRs with owner names starting with the label "*".  "Such RRs are
      called 'wildcards'.  Wildcard RRs can be thought of as
      instructions for synthesizing RRs."  (Quoted from [RFC1034],
      Section 4.3.3) For an extended discussion of wildcards, including
      clearer definitions, see [RFC4592].

All of RFC 4592 is about the use of wildcards in the DNS.

--Paul Hoffman
_______________________________________________
Public mailing list
[email protected]
https://cabforum.org/mailman/listinfo/public

Reply via email to