On 01. 04. 2018 13:22, Sherif Omran wrote:
i created a thin linux image using yocto and i have pulseaudio in the system being installed. But when i start it manually, i get pulse is not intented to start as root. I tried to enable the spawn but even it has not been solved. I have systemv, does it cause a problem?

Search for "pulseaudio system mode". This page is a good start:


I got PulseAudio running on an embedded system using system mode generally following the instructions on that page. It works, but it will complain a lot in the logs about running as root.

You also need to disable all the different ways PA gets automatically spawned in user mode (at least under systemd that is quite a pain: you have the autospawn feature - /etc/pulse/client.conf and /etc/pulse/client.conf.d/00-disable-autospawn.conf, the systemd per-user units and possibly some other ways I haven't figured out - I still get a spurious non-system mode PA daemon spawned sometimes).

You also (usually) need to have PULSE_RUNTIME_PATH=/var/run/pulse environment set for clients.

Best regards
pulseaudio-discuss mailing list

Reply via email to