On 8/28/07, Raymond Hettinger <[EMAIL PROTECTED]> wrote: > > On Aug 27, 2007, at 6:16 PM, [EMAIL PROTECTED] wrote: > > > >> I would like to see PEP 8 remove the "as necessary to improve > >> readability" in the function and method naming conventions. That > >> way methods like StringIO.getvalue() can be renamed to > >> StringIO.get_value(). > > Gratuitous breakage -- for nothing. This is idiotic, pedantic, and > counterproductive. (No offense intended, I'm talking about the > suggestion, not the suggestor).
Scale up. If X is the amount of pain inflicted by breaking the method name and X/10 per year is the amount gained due to improved api predictability, then the investment pays off in only 10 years. Everyone using Python 5k will thank you for it. Besides, with deprecations, changing api isn't that painful. > Ask ten of your programmer friends to write down "result equals object dot > get value" and see if more than one in ten uses an > underscore (no stacking the deck with Cobol programmers). I wonder how many will write down "result equals object dot get value".... :) -- mvh Björn _______________________________________________ Python-3000 mailing list Python-3000@python.org http://mail.python.org/mailman/listinfo/python-3000 Unsubscribe: http://mail.python.org/mailman/options/python-3000/archive%40mail-archive.com