Chris Jerdonek added the comment:

> Any interest in doing like os.get_terminal_size/shutil.get_terminal_size

If functions with two different behaviors are needed, I think the two functions 
should probably have different names (e.g. get_shell() and get_user_shell()).  
Otherwise, it may create confusion as to which to call (or which is being 
called when reading code).

Moreover, it doesn't seem like the following guidance in the docs for which 
get_terminal_size() to use would hold in parallel for the shell variants: 
"shutil.get_terminal_size() is the high-level function which should normally be 
used, os.get_terminal_size is the low-level implementation."


Python tracker <>
Python-bugs-list mailing list

Reply via email to