Steve Dower added the comment:

What can I do to help move this along?

It sounds like for Windows builds we could change _imp.extension_suffixes() 
from ['.pyd'] to ['.{}.pyd'.format(distutils.util.get_platform()), '.pyd'] and 
update distutils to produce the more specific name (I've got some work to do on 
distutils anyway for 3.5, so I'm happy to do this part). This would also 
include somehow hard-coding the get_platform() result into the executable 
(probably a #define in pyconfig.h)

I'm more inclined towards get_platform() than adding new architecture tags. 
Windows at least doesn't support fat binaries - the closest equivalent is 
universal apps, which use separate binaries and a naming convention. Adding a 
debug marker here would also be nice, as I've never been a huge fan of the "_d" 
suffix we currently have, but it's not a big deal.

I suspect any changes here would be completely separate from other platforms, 
but ISTM that we're looking at a similar change to handle the bitness/debug 
issue on Linux. I'm not volunteering to do that part :)

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue22980>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to