STINNER Victor added the comment:

issue22635-3.diff: LGTM.

R. David Murray: "I disagree with Victor.  The name of the function is 
"getstatusoutput".  I think the docs should continue to use (status, output) as 
the names for the return values."

In Python, we use "exitcode" or "returncode" names for the exit code, but 
"status" for the thing that should be parsed with os.WEXITSTATUS(status).

Just to contradict me, the manual page of the exit() function uses the "status" 
term: "void _exit(int status);", not "code".

"The clarification is that 'status' is now the raw return code, not the shifted 
return code that it formerly returned."

Sorry, I'm confused by this sentence :-) getstatusoutput() returns an exit 
code, the parameter of exit(), no more the annoying "status" thing that should 
be passed to os.WEXITSTATUS(status) to get a regular exit code.

"Also, the patch should include a new test that checks the actual return code 

FYI acassaigne is a newcomer currently in a sprint and this issue is tagged as 
Documentation. I suggest to first push a doc change and then add an unit test.


Python tracker <>
Python-bugs-list mailing list

Reply via email to