Nathaniel Smith added the comment:

> Would it be possible to upgrade the "manylinux" compiler (take a more recent 
> GCC version)?

No, it's possible :-(. 4.8.2 is the very most modern version of GCC you can use 
if you want to build binaries to run on CentOS/RHEL 5. (And "binaries should 
run on CentOS/RHEL 5" is the definition of manylinux1.)

I am a bit confused that gcc 4.8.2 is having trouble with cpython 3.6.0b2, 
though -- supposedly anything newer than gcc 4.3 should be fine with it. And 
yet. One possibility is that something funny is going on inside the build 
scripts Robin's using and that Python's ./configure is somehow finding and 
using the platform compiler (gcc 4.1) even though the first "gcc" in $PATH is 
4.8.2, which would make this a false alarm.

nosy: +njs

Python tracker <>
Python-bugs-list mailing list

Reply via email to