Zachary Ware <> added the comment:

Ok, Yury clarified a few points before I got my message submitted there, so 
some of my last message may be a bit misguided.  In particular, the problems 
with just using `` are clearer to me now.

To give my answers to Yury's open questions:

- We should have an async setUpClass capability, one way or another.

- I would say event loop per class.  If someone really needs event loop per 
method, they can create separate classes per method.  It's ugly, but effective.

- We should have an async setUp capability.  Maybe we could add a helper method 
to be called from setUp rather than adding a whole new asyncSetUp into the 
protocol?  That eliminates the problem of which goes first.


Python tracker <>
Python-bugs-list mailing list

Reply via email to