On Sun, 26 Jun 2005, Phillip J. Eby wrote: > * drop getcwd(); it makes no sense on a path instance
Personally I use path.getcwd() as a class method all the time. It makes as much sense as fromkeys() does on a dict instance, which is technically possible but non-sensical. > And, assuming these file-content methods are kept: > > * path.bytes() -> path.get_file_bytes() > * path.write_bytes() -> path.set_file_bytes() and path.append_file_bytes() > * path.text() -> path.get_file_text() > * path.write_text() -> path.set_file_text() and path.append_file_text() > * path.lines() -> path.get_file_lines() > * path.write_lines() -> path.set_file_lines() and path.append_file_lines() I don't know how often these are used. I don't use them myself. I am mainly interested in this module so that I don't have to use os.path anymore. Reinhold Birkenfeld wrote: > One more issue is open: the one of naming. As "path" is already the > name of a module, what would the new object be called to avoid > confusion? pathobj? objpath? Path? I would argue for Path. It fits with the recent cases of: from sets import Set from decimal import Decimal -- Michael Hoffman <[EMAIL PROTECTED]> European Bioinformatics Institute _______________________________________________ Python-Dev mailing list Python-Dev@python.org http://mail.python.org/mailman/listinfo/python-dev Unsubscribe: http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com