Hello Nick, Ethan,

The Python Steering Council reviewed PEP 467 -- Minor API improvements for 
binary sequences at our 2021-07-26 meeting.

Thank you for work on this PEP.  We’re generally very favorable for adding to 
Python 3.11 the features and APIs described in the PEP.  We have some requests 
for changes that we’d like you to consider.

* The Python-Version in the PEP needs to target Python 3.11 of course.

* We think it would be better if bytes.fromsize()’s second argument was a 
keyword-enabled or keyword-only argument.  We understand the rationale given in 
the PEP for not doing so, but ultimately we think the readability of (at least 
allowing) a keyword argument to be more compelling.  Some possible options 
include `fill`, `value`, or `byte`.

* We all really dislike the word “ord” as in `bytes.fromord()`.  We understand 
the symmetry of this choice, but we also feel like we have an opportunity to 
make it more understandable, so we recommend `bytes.fromint()` and 
`bytearray.fromint()`.

* We think the `bchr()` built-in is not necessary.  Given the `.fromint()` 
methods, it’s better not to duplicate the functionality, and everything has a 
cost.  A built-in that exists only for the symmetry described in the PEP is 
just a little extra complexity for little value.

Let us know what you think about making these changes.  We aren’t making 
acceptance contingent on these changes, but we do think they make the PEP and 
the new APIs better.

-Barry (on behalf of the Python Steering Council)

Attachment: signature.asc
Description: Message signed with OpenPGP

_______________________________________________
Python-Dev mailing list -- python-dev@python.org
To unsubscribe send an email to python-dev-le...@python.org
https://mail.python.org/mailman3/lists/python-dev.python.org/
Message archived at 
https://mail.python.org/archives/list/python-dev@python.org/message/PJQPR2CGMKTBADB66GCFHYASYHZGQRT2/
Code of Conduct: http://python.org/psf/codeofconduct/

Reply via email to