Greg Ewing wrote:
Instead of defining things directly in foo.py, maybe it
should do
try:
from cFoo import *
except ImportError:
from pyFoo import *
Then the fast path will be taken if cFoo is available,
and you can directly import cFoo or pyFoo if you want.
For what it's worth, I like that naming convention better than the
current conventions Foo/cFoo, Foo/_Foo.
--
Steven
_______________________________________________
Python-Dev mailing list
Python-Dev@python.org
http://mail.python.org/mailman/listinfo/python-dev
Unsubscribe:
http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com