On 2010-05-21, Brian Quinlan wrote: > The PEP is here: > http://www.python.org/dev/peps/pep-3148/ [snip]
Hi Brian, Could I suggest a small subtle changing in naming: replace "executor" with "executer"? I guess this suggestion is doomed though since Java uses executor:-( I'd also be tempted to rename "submit()" to "apply()" in view of Python's history. Also, maybe change "done()" to "finished()" since the function returns True if the call was cancelled (so the job can't have been "done"), as well as if the call was finished. Actually, having read further, maybe the best name would be "completed()" since that's a term used throughout. Perhaps call the "not_finished" set "pending" since presumably these are still in progress? (My understanding is that if they were cancelled or finished they'd be in the "finished" set. I'd also rename "finished" to "completed" if you have a "completed()" method.) I think FIRST_COMPLETED is misleading since it implies (to me anyway) the first one passed. How about ONE_COMPLETED; and similarly ONE_EXCEPTION? I think it would be helpful to clarify whether the timout value (which you specify as being in seconds) can meaningfully accept a float, e.g., 0.5? Anyway, it looks like it will be a really nice addition to the standard library:-) -- Mark Summerfield, Qtrac Ltd, www.qtrac.eu C++, Python, Qt, PyQt - training and consultancy "C++ GUI Programming with Qt 4" - ISBN 0132354160 _______________________________________________ Python-Dev mailing list Python-Dev@python.org http://mail.python.org/mailman/listinfo/python-dev Unsubscribe: http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com