Den 2016-09-20 skrev Chris Angelico <>:
> On Wed, Sep 21, 2016 at 6:21 AM, Martin Schöön <> 
> wrote:
>> Den 2016-09-19 skrev Lawrence D’Oliveiro <>:
>>> On Tuesday, September 20, 2016 at 8:21:25 AM UTC+12, Martin Schöön wrote:
>>>> But -- now I tested using emacs instead using C-c C-c to execute.
>>>> Noting happens so I try to run the program from command line and
>>>> find that now Python can't stand my å, ä and ö.
>>> What version of Python? Python 3 accepts Unicode UTF-8 as a matter of 
>>> course.
>> Python 2.7.
>> I just tried running my code in Python 3 and that worked like charm.
> Then you've found the solution. Py2's Unicode support is weaker than
> Py3's, and it often depends on encodings.
Yes, so it seems. I have told emacs to invoke python3 instead of python
and then it worked like just fine.

I assume there is a setting somewhere in Geany that tells it to run
python3 rather than python but I have failed to find it.

Case closed as far as I am concerned.

Thanks for the help and patience.


Reply via email to