On Tue, 2009-04-28 at 17:40 +0200, Jelle Feringa wrote: > > Oh, I thought the idea was to remove the "BRep_" part of the class > > names. Sorry if I misunderstood! > > - Frank > > No worries, that would be silly ;') > Just going from `from OCC.BRep import *` -> `from OCC import BRep`
Uh Oh. This is sounding confused. Sorry if I have not been clear: I *am* proposing to remove the "BRep_" part of the class names, for classes in the OCC.BRep pacakge. For example: OCC.BRep.BRep_Builder() -> OCC.BRep.Builder() OCC.BRepPrimAPI.BRepPrimAPI_MakeBox() -> OCC.BRepPrimAPI.MakeBox() OCC.Geom.Handle_Geom_Circle() -> OCC.Geom.Handle_Circle() OCC.Geom.Geom_Circle() -> OCC.Geom.Circle() OCC.gp.gp_Pnt() -> OCC.gp.Pnt() I don't regard this as a deviation of from the C++ API. Ultimately, it's a consistent translation from "_" (C++ API) to "." (python API). It's because of the importance of API stability that I want to make this proposal now (maybe it's already too late. That's why I'm asking). I'm grateful for the feedback on this. I don't want to spend time on a patch which will ultimately be unacceptable to the rest of the pythonOCC devs/users. Bryan C > _______________________________________________ Pythonocc-users mailing list Pythonocc-users@gna.org https://mail.gna.org/listinfo/pythonocc-users