Hi Bryan
I must admit that I am not convinced of my own opinion regarding this
;-) My initial instinct when I first used pythonocc was exactly the
same as what you propose below, i.e. it felt really silly to be
repeating the package part in the class name.
Yet, I now have this nagging feeling that we shouldn't be messing with
the naming, but the more I think rationally about it, the less real
reason I see for my doubt!
So I will change my vote from -1 to 0, and let the discussion
continue... maybe by tomorrow I will vote +1!
Cheers,
Frank
Bryan Cole wrote:
On Tue, 2009-04-28 at 17:40 +0200, Jelle Feringa wrote:
Oh, I thought the idea was to remove the "BRep_" part of the class
names. Sorry if I misunderstood!
- Frank
No worries, that would be silly ;')
Just going from `from OCC.BRep import *` -> `from OCC import BRep`
Uh Oh. This is sounding confused. Sorry if I have not been clear: I *am*
proposing to remove the "BRep_" part of the class names, for classes in
the OCC.BRep pacakge.
For example:
OCC.BRep.BRep_Builder() -> OCC.BRep.Builder()
OCC.BRepPrimAPI.BRepPrimAPI_MakeBox() -> OCC.BRepPrimAPI.MakeBox()
OCC.Geom.Handle_Geom_Circle() -> OCC.Geom.Handle_Circle()
OCC.Geom.Geom_Circle() -> OCC.Geom.Circle()
OCC.gp.gp_Pnt() -> OCC.gp.Pnt()
I don't regard this as a deviation of from the C++ API. Ultimately, it's
a consistent translation from "_" (C++ API) to "." (python API).
It's because of the importance of API stability that I want to make this
proposal now (maybe it's already too late. That's why I'm asking).
I'm grateful for the feedback on this. I don't want to spend time on a
patch which will ultimately be unacceptable to the rest of the pythonOCC
devs/users.
Bryan C
_______________________________________________
Pythonocc-users mailing list
Pythonocc-users@gna.org
https://mail.gna.org/listinfo/pythonocc-users
_______________________________________________
Pythonocc-users mailing list
Pythonocc-users@gna.org
https://mail.gna.org/listinfo/pythonocc-users