Quoting Eric Blake (2015-02-17 09:26:12) > On 02/16/2015 08:14 PM, Michael Roth wrote: > > From: zhanghailiang <zhang.zhanghaili...@huawei.com> > > > > Introduce three new guest commands: > > guest-get-memory-blocks, guest-set-memory-blocks, > > guest-get-memory-block-size. > > Sorry for the late review, but I think guest-get-memory-block-size is > the wrong command to add. > > > > +## > > +# @guest-get-memory-block-size: > > +# > > +# Get the the size (in bytes) of a memory block in guest. > > +# It is the unit of memory block online/offline operation (also called > > Logical > > +# Memory Hotplug). > > +# > > +# Returns: memory block size in bytes. > > +# > > +# Since 2.3 > > +## > > +{ 'command': 'guest-get-memory-block-size', > > + 'returns': 'int' } > > Any QAPI command that returns a bare int instead of a dictionary is > non-extensible, and therefore of suspect design. I think it would be > better to have: > > { 'command': 'guest-get-memory-block-info', > 'returns': { 'size': 'int' } } > > to allow for future extension.
It seems like a reasonable suggestion to me. I can change it in my tree if there are no objections. zhanghailiang? > > -- > Eric Blake eblake redhat com +1-919-301-3266 > Libvirt virtualization library http://libvirt.org