On 13 April 2018 at 16:28, Halil Pasic <pa...@linux.vnet.ibm.com> wrote:
> On 04/13/2018 04:30 PM, Thomas Huth wrote:
>> "size_t" should be an unsigned type - the signed counterpart is called
>> "ssize_t" in the C standard instead. Thus we should also use this
> The first sentence sounds like ssize_t is too a type defined by some
> C standard. Is it or does ssize_t come form somewhere else? I find negative
> size a little difficult conceptually.
I think ssize_t is from POSIX:
"Used for a count of bytes or an error indication".