Hi,
I am running 'latest and greatest' opensuse linux, and the related
packages, including QGIS 2.16.1, on a x64 machine.

I am having trouble with some plugins (profile tool being the one I
care about today) but I get the following error quite frequently:

RuntimeError: module compiled against API version 0xa but this version
of numpy is 0x9


I have opened a python shell, and "Print(numpy.__version)" gives me
1.8.0.  I believe this is the current version distributed with
OpenSuse.  I also believe the current version of numpy is 1.11.1.

Can someone explain what numpy versions of 0xa and 0x9 in the qgis
error message mean? (hex values of decimal 10 and 9, I know but how this
relates to my version of 1.8.0 I don't know)

Should I 'just' install the latest version of numpy from
http://www.numpy.org/ or are there some 'gotchas' I should be careful
of...

With thanks
_______________________________________________
Qgis-user mailing list
Qgis-user@lists.osgeo.org
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

Reply via email to