So I've got an update on this.

If I run this with the command line (gdal 2.1):

gdalwarp -cutline acid_forest_buffer.shp low_east.tif output.tif
/Processing input file low_east.tif.//
//Using internal nodata values (e.g. -3.40282e+38) for image low_east.tif.//
//Warning 1: Self-intersection at or near point 2309.5402184630693 1121.2793755624425//
//ERROR 1: Cutline is not valid after transformation/

I had one community member confirm the clip works in 2.14.1. I think ultimately this is a gdal version problem - sort of.

If I look at the shapefile in QGIS I get an error using the topology tools looking for overlaps. I seem to have 2 multipolygons in this data. I clean those up and the tool runs as expected.

Is there something with gdal 2.1 that chokes with a multipolygon in running this type of clip against a raster?

On 10/07/2016 09:27 AM, Randal Hale wrote:

I've tried this on:

  * 2.14.6 on Windows
  * 2.16.3 on Linux
  * Master on Linux

Dropbox Link:

I have a raster and polygons. All matching in projection. M one worry is the raster is a float32 tiff and something it wrong with it. I didn't create the raster but I am trying to help someone work their way through this exercise for a College Class.

When I use the processing tool to clip the raster with the vector I get an output image that in the legend shows the values as being nan - which I guess is null. No matter what I do - there is no clip. Just a large image that is black or nan (null).

Thoughts? I'm stuck. I don't know if I'm seeing a bug or I've got a bad image. The person originally working through this said it all works correctly with 2.8 (but I haven't attempted that version as of yet).


Randal Hale
North River Geographic Systems, Inc

Randal Hale
North River Geographic Systems, Inc

Qgis-user mailing list
List info:

Reply via email to