Right now, the ServiceLocator is not a separate instance, and if that is made into a separate implementation, and always used, it is very clear where to go looking for bugs. I like separation of concerns. ;o)
Cheers Niclas On Mon, May 5, 2008 at 11:49 PM, Rickard Öberg <[EMAIL PROTECTED]> wrote: > > Niclas Hedhman wrote: > > On Mon, May 5, 2008 at 11:00 PM, Rickard Öberg <[EMAIL PROTECTED]> wrote: > >> I agree that this is a complete mess, and needs to be fixed up. I agree > >> that the names suggested is a good way to do it (get vs find), and maybe > >> we should extend this so that the current ServiceLocator is renamed to > >> ServiceFinder and then have findService/findServices rather than > >> lookupService/lookupServices. And *then* rename EntityFinder.find to > >> findEntities and add findEntity (single), and it should be reasonably > >> symmetric and semantically well-defined. > > > > Would that also mean that one ask for the ServiceFinder from the > > Module, or still have the methods on the Module? The latter has some > > advantages.... > > Can you expand on this? I don't have any strong opinions myself on this one. > > > > /Rickard > > _______________________________________________ > qi4j-dev mailing list > [email protected] > http://lists.ops4j.org/mailman/listinfo/qi4j-dev > _______________________________________________ qi4j-dev mailing list [email protected] http://lists.ops4j.org/mailman/listinfo/qi4j-dev

